bundle exec jekyll serve 运行报错Dependency Error: Yikes! It looks like you don't have kramdown-math-katex

Winter · 11月08日


安装完jekyll后,运行指令bundle exec jekyll serve后报了如下错误:


Dependency Error: Yikes! It looks like you don't have kramdown-math-katex or one of its dependencies installed. In order to use Jekyll as currently configured, you'll need to install this gem. If you've run Jekyll with `bundle exec`, ensure that you have included the kramdown-math-katex gem in your Gemfile as well. The full error message from Ruby is: 'cannot load such file -- kramdown-math-katex' If you run into trouble, you can find helpful resources at https://jekyllrb.com/help/!
 Conversion error: Jekyll::Converters::Markdown encountered an error while converting '_posts/2019-08-06-this-is-yld.md':
                   kramdown-math-katex
            ERROR: YOUR SITE COULD NOT BE BUILT:
                   ------------------------------------
                   kramdown-math-katex
                   ------------------------------------------------
     Jekyll 4.0.0   Please append `--trace` to the `serve` command
                    for any additional information or backtrace.
                   ------------------------------------------------


 


 

image widget

回答(1)
时间
W
Winter
1 · 2019-11-08 10:46:26

首先在你的项目中找到Gemfile文件,然后在代码中添加

gem "kramdown-math-katex"

你的回答

加载中...
⌘+Return 发表
发表

温馨提示:登录后可发表评论或回复

关闭,朕知道了

扫码关注微信公众号或小程序